Can't run FormSample

Oct 21, 2010 at 7:18 AM

Hello,

I m trying to run FormSample from the trunk directory and i got AccesViolationException on line 37 :

webView.LoadUrl("http://www.google.com");

I m using awesomium 1.6 rc1 with awesomiumdotnet 1.6 rc1.

Any clue on this ?

Thanks for your help.
Coordinator
Oct 28, 2010 at 10:23 AM

It seems that the .NET 4.0 version doesn't work very well. This may be because AwesomiumDotNet was compiled with MSVC10 against Awesomium that was compiled with MSVC9.

There is no Awesomium release for MSVC10 yet, but we need MSVC10 in order to support .NET 4.0.

Oct 28, 2010 at 6:43 PM

Thanks.
I move back to 1.2.1 with 1.5.1 under vs2008 and everything is working fine

Coordinator
Oct 31, 2010 at 8:19 AM

Version 1.6 RC1 for .NET 2.0 (the regular one) shouldn't have this problem. Have you tried it?

Nov 15, 2010 at 3:47 AM

Hello,

I have the same problem with the MOGRE sample. I tried running the code with reference to the normal awesomiumdotnet, then with the one that has "-net4" which I assume is a version compiled with vs2010.

But still, I get "AccessViolationException, Attempted to read or write protected memory..." Every time. Now there's the new regular awesomium rc2 and I tried it also, and the error changed position, but still it happens again, this time in "view.IsDirty".

 

Do you know what might be causing this access violation?

 

I see you are still committing changes to the source repositories. Unfortunately my c++ is not up to par to the task of helping you with this. Now that rc2 has been released, do you think you might be able to solve this problem?

 

I tried compiling some of your source commits, including the rc1, but I couldn't, it got stuck in an abstract class not being able to be initialized (again, my c++ is not so good). 

 

The application I want to use awesomium with can't do without .net 4 because of all the new threading tools, so I'm pretty much tied to the outcome of your efforts :)

 

Also, sorry for bumping this, but the error is related and the post isn't that old.

 

Thank you for your time.

Coordinator
Nov 15, 2010 at 6:47 PM

Hi,

RC2 still doesn't seem to work right with .NET 4.

I'm not sure exactly what the problem is, but if it's that MSVC9 and MSVC10 are not compatible, then we might have to wait for quite a while, because Chromium is still only compiled with MSVC8 and MSVC9.