Could not load file or assembly 'AwesomiumDotNet *SOLVED*

Oct 21, 2010 at 1:06 AM
Edited Oct 21, 2010 at 1:06 AM

Hello everyone. I'm using visual c# express 2008, and the newest version of ADN.

I get this when I start my application, then click on where the webview is supposed to be. I have ADN as a Reference, and here is my code : 

 

WebCoreConfig config = new WebCoreConfig();
            //config.SetEnablePlugins(true);
            config.SetLogLevel(LogLevel.None);
            WebCore webCore = new WebCore(config);

            webView = webCore.CreateWebView(tabPage1.Size.Width, tabPage1.Size.Height);
            webView.LoadFile("./data/welcome/welcome.html");

 

I have tried rearranging code and what not, but I always get that. I am running windows 7 64bit also.

Please help me out, I would love to use this in my new website editor project instead of a crappy embedded IE window. Thanks.

Edit: Full error :

Could not load file or assembly 'AwesomiumDotNet, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Coordinator
Oct 21, 2010 at 7:59 AM

Awesomium is 32-bit, so your application should be 32-bit as well. Set the platform to x86 in the configuration manager. In most cases, there is no performance loss when running 32-bit applications under a 64-bit OS.

"Any CPU" fails, because it tries to load AwesomiumDotNet as 64-bit on a 64-bit machine.

If your application needs to be 64-bit, then you have to wait until there is a 64-bit version of Awesomium.

Oct 21, 2010 at 7:33 PM

Thank you so much! I had some hints from other errors with different libraries that acted the same way.  I will try that out when I get home and report back. Thanks again!